Troubleshooting

Experiencing Crashes?

For those who are experiencing crashes, this tool will likely fix the issue:

4GB Patch Tool

Quote: “This small tool patches x86 executables in order to let them have 4GB (instead of only 2) of virtual memory on x64 platforms. This is handy for applications which need a larger amount of virtual memory like games, 3D renderization, multimedia etc.”

And the file you need to patch is typically found here:

C:\Program Files (x86)\Steam\SteamApps\common\Resident Evil 4\Bin32\bio4.exe

The patch tool will automatically create a backup file, so the original bio4.exe won’t be lost.

Thus far those who have patched the exe file have no longer experienced crashes. We hope this helps anyone else having a similar issue!

71 Responses to Troubleshooting

  1. Snow Gabe says:

    Does this fix antivirus-related crashes? The game constantly freezes on levels 3-1 and 1-3. I’m using Bitdefender.

  2. William Adkins says:

    Hi, I just got done downloading your entire village HD texture pack, however there is no bat file in it. Just a folder that says RE4HDTEX. Is the bat file in a separate download somewhere? This is amazing work and I’d like to run it. Looks similar to the HD texture work I run in Skyrim. Thanks, BIll

  3. M says:

    Hi, so i’m having some stuttering problems. They are definitely not due to my hardware, as I have no stuttering with any of my other games (GTAV runs fine, for example). I have used the 4GB patch tool and still have stuttering whenever more than 4 or so enemies are on screen at once. The first village area with the cop on the cross, stutters to a crawl.

    Any help would be appreciated. Thank you and keep up the phenomenal work, I can’t wait to see the finished project!

    • albert says:

      Hello!
      Did you experience similar issues before installing the Village Texture Pack?
      Did you apply the Village Texture Pack on a “clean” RE4 installation? (Just in case you used some kind of mods before installing our texture demo)

  4. Zhe Xun says:

    Hello!
    I am grateful to play the village HD texture produced by you , but I always experience shutting down of the game at exiting the gate of 2-3 (battle just after the village head). It did not happened before I install the HDTEX. So would you please help me to solve this problem? Thanks for your help.

    • Cris says:

      Hi there! Can you confirm whether you’ve applied the 4GB Patch tool (mentioned above) to the exe file?

      • Zhe Xun says:

        Thank you for your response! I have download the 4GB patch and applied it. I saw the file called “Bio4.exe.backup”. However, the crash still happened. I have tried many ways, but I can not solve this. I have beaten the village head innumerous times, but I still could not pass the gate……

  5. Jesus says:

    Hello awesome job guys, unfortunately I keep getting 2 errors when unpacking the first is “checksum error IN RE4HDTEX\HDTexturePacks\0100000f.pack. the file is corrupt and the second just says unexpected end of archive I’ve tried downloading multiple times and the same thing happens

  6. Jesus says:

    It’s 3.97GB

  7. Dave says:

    Do I just drag and drop the 4gb patch into the bin32 folder?

    • albert says:

      If I recall correctly… just execute that tool and then select the bio4.exe as target file. Then the tool will create a new patched bio4.exe file and a backup of the original file. There’s no need for the tool to be inside the bin32 folder 😉

  8. Philipp says:

    If i run the game:
    I can only see a white screen but i hear game sounds like the menue and stuff. So the game is running but my screen is just white.

    I use Win 10 and i installed the village demo texture pack as instructed! (installed without problems)

    • albert says:

      Hello Philipp,
      Did you experience that issue before installing our texture patch?

      • Philipp says:

        Hey! you guys seems to do great work, hope i can enjoy it too, so:

        before installing the texture pack the game runs normally. I did not changed anything in the options. I just started the game and then i quitted again to install the texture pack.

        looking forward for your help, thx a lot!

        • albert says:

          Could you check if 44000120.pack and 44000100.pack files are inside Resident Evil 4\BIO4\ImagePackHD folder?
          I’m assuming you followed the “Windows 10 users” instructions. Am I right?
          Let’s see if we can find the root of the problem!

          • Philipp says:

            The files you told me to check are in the named folder. Yes i installed it as instructed.

            Meanwhile i deinstalled RE4 and installed it again. And without installing the texture pack, the screen turns white immediately after starting the game. So it might be a problem with the game itself. It´s just funny because the first time i started RE4, it ran normally.

          • albert says:

            Oh it seems something happened in your computer. Maybe you should try going back to a restore point previous to the date the game stopped working. Or you could try asking at the Steam forums:
            https://steamcommunity.com/app/254700/discussions/
            I’m sorry I can’t be of much help…

  9. Tormekian says:

    Hi. This is really a great job you have got here. However, I’ve got the same problem as William Adkins below.
    I downloaded village HD texture pack, and there is no bat file.

  10. Andrew says:

    Hey, i’ve been having some crashing problems, so I downloaded your fix and used it on bio4.exe. Unfortunately, now it is giving me this error code when I attempt to launch the application: “The applications was unable to start correctly (0xc0000142). Click OK to close the application.” I’ve tried running in administrator mode, and it produces the same effect. Any help would be great!

    • albert says:

      Hello Andrew.
      Did you experience the crashes before installing our texture pack?

    • Vini says:

      Hello RE4 HD Project team. I’m having this same problem! I was already in Salazar’s Castle. I’ve payed the village part with the textures pack just fine and whien i got at the castle, I saved the game and downloaded the castle’s texture and the crash fix tool. I don’t know whhat to do! Please help me. The game is beautiful btw, great job!

      • albert says:

        Hello! and thanks!
        Are you using a legit copy of the game? We are aware some issues happen after using the 4GB patch tool in pirated versions of the game

  11. Michael says:

    A&C

    The work you both have done is top-notch. I’m slowly moving through the castle checking everything. Very, very cool. Beautiful stuff.

    My question;
    I’ve run into a slight issue; the game is continuing to freeze at a particular spot in the game, everytime without fail. The area of the game concerned is section 3-3-Cage Dropping/hour-glass-in-chest room. Whenever I try and exit the room through the progress-door, the game drops.

    I’m on Windows 7 64-bit. I added the 4GB patch but kept receiving this error:

    “The applications was unable to start correctly (0xc0000142). Click OK to close the application.”

    I plan to erase the game, and do a fresh install. My question is regarding the location of save files. I’d like to pick-up where I left off.

    Thanks for taking an amazing game and giving it new life!

    • albert says:

      Hello Michael! And thanks for taking the time to pay attention to all the details 🙂
      Could you check if 4400020f.pack file is in your ImagePackHD folder and r20f is in st2 folder? They are the files for the blue columns room after the cage dropping area
      If 4GB patch is applyed I don’t see right now any reason the game crashes other than those files are missing or corrupted hum…
      I can’t check it right now but I’l let you know the exact savegame file location later 😉

      • Michael says:

        Albert,

        Both of the files listed above appear to be in their proper folders.

        The game itself was not installed on the C:/ drive but rather the D:/ drive (a second solid state drive)

        Could that have anything to do with the issue as the game should be in C:\Program Files (x86) ???

        • albert says:

          Hummm I don’t think the path was a problem. If it was, the entire castle pack shouldn’t be properly installed and this is not the case.
          So, right now the only suggestion I have for you is to try a fresh install as you said…
          The savegame file is here:
          C:\Program Files (x86)\Steam\userdata\164553742\254700\remote
          or imply search for “savegame00.sav”
          Please, let us know if you find the file and if you are able to solve the issue!
          Greetings

  12. Wetalo says:

    Hey guys! Your mod is phenomenal, but I’m experiencing a bug now. I just finished the Village, which worked flawlessly and now entered the castle section. So I’m fighting the cultist enemies for the first time and for some reason that enemy type has no sound? Was wondering if the texture pack might have somehow affected that.
    Thanks, guys!

    • albert says:

      Hi!
      Thank you!
      Could you tell us in which room and which enemies exactly suffer that bug?
      We included one sond file that fix one Garrador missing sound (the scream when you shot the weak point in his back was missing) but we didn’t notice any side effect after editing that file. Other than this, the textures and models shoudn’t affect in any way the sounds as far as I know…

      • Kenji says:

        Hi !
        I’ve also got this problem. It’s the cultist enemies in black costumes whom you first encounter in the castle level (right after the bridge, and they are very popular) don’t make any sound at all, even when shooting at ’em or that unique sound they usually make (boo-boo-ah-be-be or something like that). It’s kinda missing after I install your patch. That seems to be the only problem I’ve got with your patch. Pretty impressive work I must say. Thank you very much for this.

        • albert says:

          Hello!
          Thanks for letting us know about this. Could you try something for us?
          Could you restore the original files inside Snd folder? Only the em11 file (or something like this, I cant check it right now). You ll find that file inside the backup folder. Place it again inside BIO4/Snd folder. Let us know if this solved the issue. 🙂

          • Kenji says:

            OK I did what you said and the sound is coming back again. I had to ask my friend for the original files because I don’t see any backup folders. There are 2 original files (em11.xsb and em11.xwb) to replace 1 modded file (em11.xsb). Is there any missing hd textures if I do this? Thank you for your support. Really appreciate it. =))

          • albert says:

            Oh at lest we know what caused that. No problem! This file only contains sounds for some enemies. All textures models and light edits will remain untouched.

            It’s strange because it is not a problem in most computers but for some reason it is for a few people. So we’ll do some research about what could cause this.

            It is possible you experience some other sound bug when you reach room 212 (descending ceiling and Queen’s Grail area) because I also edited the sound file for that stage.
            Please, let us know if you notice some other sound glitches! But if everything is ok in that area I can imagine what caused the enemies bug…

            Thank you again!

          • Kenji says:

            Good to hear that Albert. I’ll continue the game and let you know if there is any other bugs. Thank you! 🙂

  13. Onslaught says:

    After installing the castle file and applying the 4gb patch, im getting 0xc0000142, im not having problem with
    The village file though at first, but now i cant play re4 anymore

    My pc uses windos xp 32 bit. . .

    • Cris says:

      Oh, that makes sense. The 4GB patch is applicable for who are on a 64-bit operating system. In your particular case, you should revert back to the normal exe file. I’m sorry this isn’t an option for your system! 🙁

  14. Denis says:

    Hi Albert, or Cris, I installed the Castle Release and the Village Release, and I’m playing the game on Professional Mode, as soon as I use Mendes eye on the door to the Castle, the game crashes.

    I tried installing the Castle Release again, and I noticed in the batch file that there are some problems finding some files, for example:
    O sistema não pode encontrar o arquivo especificado.
    Successfully moved file to the backup folder: em11.xgs
    O sistema não pode encontrar o arquivo especificado.
    O sistema não pode encontrar o arquivo especificado.
    Successfully moved file to the backup folder: em11.xwb
    O sistema não pode encontrar o arquivo especificado.
    O sistema não pode encontrar o arquivo especificado.
    Successfully moved file to the backup folder: r212.xwb
    O sistema não pode encontrar o arquivo especificado.
    O sistema não pode encontrar o arquivo especificado.
    Successfully moved over new gradient file: gradient.png
    O sistema não pode encontrar o arquivo especificado.
    Successfully moved over new gradient file: gradient0.png
    O sistema não pode encontrar o arquivo especificado. (System could not find the specified file)
    Successfully moved over new gradient file: gradient1.png
    O sistema não pode encontrar o arquivo especificado.
    Successfully moved over new gradient file: gradient2.png
    O sistema não pode encontrar o arquivo especificado.
    Successfully moved over new gradient file: gradient3.png
    O sistema não pode encontrar o arquivo especificado.
    Successfully moved over new gradient file: gradient4.png

    And there are no files on the folder HDTexturePacks from the RE4HDTexCastle folder

    • Denis says:

      Also, I’m using Windows 10 64 bits and I tried to fix this crash by using the 4GB patch, but now i can’t run the game cause it gives the error 0xc0000142.

      • Gerardo says:

        It happens to me the same, could you solve it?

        • Cris says:

          Hi Gerardo! The issue Denis was experiencing was due to files not copying over during the install, not due to the 4GB patch (that’s unrelated). Did you get the same messages as Denis when you were installing the Castle release?

          • Gerardo says:

            Install the patch and now I can not run the game, I get error : 0xc0000142

          • Cris says:

            Hi Gerardo, the 4GB patch tool creates a backup of the original exe file. Could you switch back to that one and let me know if the issue persists?

          • Gerardo says:

            When I make the change I can run the game, but I still have problems in some sections of the castle where the game closes and I can not move forward

          • Cris says:

            That’s very strange! I just retried applying the patch and it continues to work. Is there anyone out there who specifically is unable to start the game after applying the 4GB patch?

  15. Miguel Araneta says:

    Hi, I recently installed the pack and I’m having slowdown/choppiness issues in the village area with the crucified cop as well. This is a clean, otherwise unmodified installation of RE4 from Steam, although I did originally install it back in 2015.

    • albert says:

      Hello Miguel. Do you only notice issues in this area?
      Which are your computer specs?
      Did you notice some slowdowns in that area before the installation of our textures?
      Thanks!

  16. Daniel says:

    Just dowloaded the castle parts right now and installed them like the way you guys showed but when i run the bat file in the game folder, the bat file cant find anything. The bat and the RE4HDTEXTCASTLE are both in the game folder. Can u help me?

  17. usman says:

    Hey guys, might be just me but for some reason I can’t load the 4gb patch install site?

  18. Gerardo says:

    Install the patch and now I can not run the game, I get error : 0xc0000142

  19. Richard says:

    Al poner el parche 4gb me sale un error la aplicación no se pudo iniciar correctamente error 0xc0000142 alguna solucion

    • albert says:

      Humm es extraño, no recuerdo otro caso similar. Qué versión del juego estás utilizando? Qué sistema operativo usas?
      Does somebody else here received a 0xc0000142 error when applying the 4gb patch?

  20. Luke says:

    when i have installed the 4gb patch the game will not run and I get error : 0xc0000142

    • albert says:

      Humm I’m not an expert but it could be related to some windows 10 update…
      I’m seeing out there hundreds of “solutions” for the 0xc0000142 error but I can’t say which one is the right one for this case…
      If anybody find out the solution, please, let us know…

  21. Shigetora says:

    The 0xc0000143 error which shows up after patching the .exe with the 4GB Patch Tool only shows up in the pirate version of the game , But I’m not 100% sure. I tried it on a pirated version of the game and it didn’t work.

  22. Richard says:

    Mm uso la versión pirata del juego crees que sea eso y otra cosa pude corregir el errór de 0xc0000142 con unos archivos que me pasaron en otro post pero el savedata que tenia ya no reconoce
    Si savedata se guarda en una carpeta skidrow

    • albert says:

      Puede que sea ese el problema. Otro usuario ha comentado lo mismo acerca de estar usando una versión pirata. En este caso no podemos hacer nada. Todo lo el proyecto está basado en la versión oficial y legal descargada mediante Steam.

  23. Richard says:

    A ok ya me lo imaginaba pues ni modo aver si mas después ai una solución
    Gracias albert

  24. Mini Gun says:

    Hey there 🙂 I m playing a mod called Life in Hell so a lot of itens are in diferent places and enemies drops keys and treasures so if I install this do the new files replace the itens locations frim the mod? Or theres a way to play the mod with the remaster project.

    • albert says:

      Hello!
      I’m afrad it will replace everything in the castle area (and only a few in the village because the pack available now is a really outdated version and it lacks a lot of files)

      Most mods will need to be redone after our project is finished because they will be incompatible because we are editing almost every file of the game…

  25. Brock says:

    I can’t install either texture update..it says 0 files copied….. I’m running window 10, I also did the method you suggested by CMD command.
    My directory for Resident Evil 4 is C:\Program Files (x86)\Capcom\Resident Evil 4
    Also, I couldn’t find any bio4.exe..it seems I don’t have steam version game.

  26. paulo says:

    I would like to know if the 4gb patch only works on the original resident evil 4 of Steam?

    • albert says:

      As far as we know, it seems the 4GB patch makes the game to crash with some pirated versions of the game. So, we can’t do anything about that…
      I’ve talked with people using the original disc version of UHD (not Steam, but not pirated) and they had no problem with the 4GB patch so far.
      But we have no enough feedback about this matter to be 100% sure about this problem.

Leave a Reply to Kenji Cancel reply

Your email address will not be published. Required fields are marked *